TOC目录
打开TOC目录
首先给系统添加 epel 源
curl -o /etc/yum.repos.d/epel-7.repo https://mirrors.aliyun.com/repo/epel-7.repo
安装证书申请工具Certbot
yum install -y certbot
验证版本的时候报错(原因是上一步安装urllib3依赖失败)
certbot --version
缺失python-urllib3包,由于版本过低引起的问题,可通过升级pip来解决这个问题
pip install --upgrade pip
问题依旧,可以使用命令
pip install --upgrade --force-reinstall 'requests==2.6.0' urllib3
运行certbot生成证书
certbot certonly -d jimtse.com -d *.jimtse.com --manual \
--preferred-challenges dns \
--server https://acme-v02.api.letsencrypt.org/directory

- 输入邮箱并回车
- 按Y并回车同意条款
- 按N并回车不同意邮箱订阅
- 按下图去域名提供商解析DNS

- 解析成功如下图

证书有效期3个月,保存路径如下
/etc/letsencrypt/live/jimtse.com/fullchain.pem
/etc/letsencrypt/live/jimtse.com/privkey.pem
由于有效期90天,最后用定时任务每个月28号自动续签证书
30 1 28 * * /usr/bin/certbot renew && nginx -s reload
最后来个docker加餐
docker run -it --rm --name certbot \
-v "/etc/letsencrypt:/etc/letsencrypt" \
-v "/var/lib/letsencrypt:/var/lib/letsencrypt" \
certbot/certbot certonly --manual -d '*.jimtse.com'